This topic has 3 replies, 2 voices, and was last updated 2 weeks, 2 days ago by SuperDroid.

  • Author
    Posts
  • #8618
     Zack S
    Participant

    I have a refurbished HD2-S tactical robot that we have been having connection issues with. At first I could not establish any connection between the robot and the OCU so I replaced the mega2560, the shield and the custom mega board and re-uploaded code. That “fixed” the issue for the rest of the day. Now my robot will randomly connect and disconnect from the OCU. I have taken the bottom panel off and can see when the robot has a connection the sabertooth(s) show blue LEDs but then will shut off when connection is lost. I have a more stable connection when unplugging PINS 4 and 5 (armEstop and armTxpin), and the power supply and reconnecting, but ultimately it will lose connection. Before this I could not get any connection, until we started experiencing this new problem. I have noticed that if I leave the USB printer cable plugged in from the computer or the wall to the mega2560 I can establish a more reliable connection but will lose it once the printer cable is unplugged from the mega. Any advice or guidance is very much appreciated, thank you.

    #8619
     SuperDroid
    Keymaster

    Hey Zack,

    How is the Arduino being powered in the robot? It seems supplying power to the Arduino through the USB cable is correcting the problem.

    #8620
     Zack S
    Participant

    We tried to power the Arduino from the the DC power jack on the robot. But we have a more reliable connection when the USB is plugged into the computer and supplying the power without the DC jack plugged in. I had also thought that the USB cable corrected the problem but while it was plugged in the base started rotating on its own so I fear that it is still an unpredictable, dangerous way of correcting the issue. Our team checked the power coming from the DC jack on the robot and it reads just under 11 volts, which I imagine shouldn’t matter a whole lot because the Arduino will regulate at 5v. A few times now we have been able to “jump” it with the USB plugged into the computer and then once a connection is established I can unplug it and run just off the power supplied from the robot. I was hoping to see if you guys have experienced this issue before and had a reliable way to fix it as this has not always worked for us.

    #8621
     SuperDroid
    Keymaster

    I would try powering the robot’s Arduino with 5 Volts through the SL header. We have had power issues with the Arduino’s 12v to 5V regulator before. As for the base moving on its own, can you counter this movement with the joysticks? I’m wondering if the joystick potentiometer is off center. If so, there is a slot on the bottom side of the joystick to recenter the pot.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Login Register

©2022 SDRobots.com | All rights reserved.

Log in with your credentials

or    

Forgot your details?

Create Account